Home/Support/Support Forum/After installing eGit, the Digi Xbee Perspective lost functionality
New and improved user forum site coming soon

After installing eGit, the Digi Xbee Perspective lost functionality

0 votes
I just started to get the hang of the Xbee SDK and running my own code so I wanted to get version control going with CVS. I learned the eGit was the recommended alternative method so I installed that into Code Warrior. That seemed to install uneventfully with a bunch of new menus in the TEAMS context.

I now don't see the nice graphic IO rendition of the config.xml nor the killer processor/IO configuration tool. I just see what looks like xml code? when I click on the config.xml file. The Perspective selector at the top right also seemed to lose the graphic icon I was used to seeing.

Help!
asked Apr 10, 2017 in XBee Programmable Development by dpguitarman New to the Community (6 points)

Please log in or register to answer this question.

1 Answer

+1 vote
All I can suggest is a removal of the update or remote and reinstall.
answered Apr 10, 2017 by mvut Veteran of the Digi Community (15,515 points)
If I uninstall code warrior it won't delete my projects as well right? I assume when I reinstall, it will recognize those projects again?
Generally no it will not as your projects should be stored in a workplace folder which is NOT under the Code Warrior application.
Thanks for the help. After uninstalling ALL, I reinstalled CW and SDK, not yet eGit. Perspective was still not working right until I loaded a Sample Application. It then started to work. I then loaded eGit and the Perspective stopped working. I uninstalled the SDK and reinstalled and all was good including eGit.
...