Home/Support/Support Forum/Why is my XBee PRO S3B giving junk data in XCTU, even after recovery was used?
New and improved user forum site going live on 12/6 (All users will need to reset their password when the new forum is active)

Why is my XBee PRO S3B giving junk data in XCTU, even after recovery was used?

0 votes
I recently bought a pair of XBee PRO S3B modules (900Mhz, 9600 baud) and a Sparkfun Xbee dongle (USB). When I run XCTU, it finds the module easily enough, and it's the correct module type, but when I load the settings into XCTU, they're mostly junk data (out of range values, etc.) - even after I reset everything to factory settings and wrote the data out, when I read it back in it's all junk again. I tried using the recovery feature to reload the firmware but the same thing keeps happening. This has happened for both modules I purchased. Did I buy faulty modules? They were bought on Amazon.com - do I need to buy from another source to avoid getting bad modules? Or am I missing something? I'm using the Mac OS X version of XCTU. Please help!
asked Jan 27, 2016 in IEEE 802.15.4 by jacobjackson1985 New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
No, they are not faulty modules. What you need to do is first optimize the USB ports for low data rate devices as described at http://knowledge.digi.com/articles/Knowledge_Base_Article/Optimizing-USB-to-serial-port-settings/?q=optimizing+usb+drivers&l=en_US&fs=Search&pn=1.

Next, if you are using the XSC version of the firmware, you will need to remove one of the LED's from the Explorer board. (Talk to Spark Fun about it).
answered Jan 28, 2016 by mvut Veteran of the Digi Community (15,515 points)
...