Home/Support/Support Forum/Firmware EOS brick for ConnectPort X4 IA ZB WiFi model?

Firmware EOS brick for ConnectPort X4 IA ZB WiFi model?

0 votes
I tried to update the latest firmware on the device (ConnectPort X4 IA ZB Wifi), and now the device isn't working...
The steps I followed from:
    Download and update the POST firmware of the device from this link in the digi support page of the product (http://ftp1.digi.com/support/firmware/82001753_K.bin)
    After I got the successful update message, I rebooted the gateway and it started successfully.
    Download and updated the EOS firmware version for the device from the same page (http://ftp1.digi.com/support/firmware/82001536_N3.bin)
    After successful update I rebooted the gateway....

After all this the device cannot boot again...
What happens is once I power on the device is:
1) The power led stays on
2) The status led flashes green with this procedure: 3, (power led blinks instantly orange), 2,6,7,3, (power led blinks instantly orange),2,6,7,3

No other leds turn on on the device and cannot be accessed or discovered through any digi discover utitlity.

I also found an article about how to restore firmware on connectport x4 on this location http://knowledge.digi.com/articles/Knowledge_Base_Article/How-do-I-recover-my-Digi-ConnectPort-X4/?q=ConnectPort+X4+IA+ZB+-+Ethernet+%26+Cellular+%28Edge%29&l=en_US&fs=Search&pn=1

I follow all the steps described in the guide successfully but with no different result...

My only consideration is that again with the recovery guide I attempt to load the new firmware I downloaded from DIGI support page, but on the support page no model reference exists for ConnectPort X4 IA ZB Wi-Fi, but only for Ethernet & Cellular (Edge). So maybe this could be a reason that the firmware is not compatible? However in the firmware release notes http://ftp1.digi.com/support/firmware/93000698_N3.txt it references all the models as compatible with this firmware...

In conclusion, I believe it is a matter of incompatible firmware with the device, and I cannot find anywhere the old firmware of our model to reflash it with the recovery procedure....

Any ideas anyone?
asked Jun 17, 2015 in NDS-based Gateways by mitsos1os New to the Community (4 points)

Please log in or register to answer this question.

2 Answers

0 votes
Best answer
You might want to try the following firmware image for legacy units:


If this does not work, you might need to contact Digi for repair/RMA
answered Jun 17, 2015 by userid0 Veteran of the Digi Community (2,158 points)
selected Jun 19, 2015 by mitsos1os
0 votes
Thank you very much for your assistance. I successfully downloaded the firmware, booted it, restored to factory default settings, re-updated to latest and now it works!
Thank you for time
answered Jun 19, 2015 by mitsos1os New to the Community (4 points)