Home/Support/Support Forum/Can't connect to Digi CM 16
New and improved user forum site coming soon
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Can't connect to Digi CM 16

0 votes
So I obtained a Digi CM16, I must say it seems like a great system for managing my Rackable Server Farm, however...I've tried to connect this device using the console port and a serial adapter. And various baud rates, and connection types using HyperTerminal, Putty, and other console applications and just can't seem to get it connected.

When it turns on there is a Power, Ready, Act, 100mps, and Link lights (and PC card but have no plan to use that).

The power turns on, after about 30 seconds, the ready light turns on and stays on (which I assumes means it's booted) and then no other lights go on.

I have connected the Cisco ethernet serial cable to the console port of the CM16, and then connected the other end which is a DB9 to the serial port (COM1) of a desktop computer.

I have set the baud rate to 9600, 8N1, and connected on COM1 of the desktop. All I get is a blank screen, no commands, no display...nothing.

I'm not sure if this means that the device is bricked, or was wiped from it's firmware.

I have tried connecting other devices using this same method, and even same connection specifics and they connect with absolutely no issues, a Cisco Switch, an Ethernet KVM, a Compaq KVM and a few other devices, so I know the cable is not bad.

Does anyone have ANY ideas what could be causing this issue. I am desperate to get this thing working as we have almost 2 racks of Rackable Servers that need an out of band management network, and I can't seem to get anything to work.

This is basically what I am attempting to setup:
asked Nov 6, 2014 in ConnectWare Manager by bradjtrammell New to the Community (4 points)
edited Nov 6, 2014 by bradjtrammell

Please log in or register to answer this question.

8 Answers

0 votes
Can you confirm the pin-outs? http://ftp1.digi.com/support/cabling/90000613_a.pdf

You might want to connect the unit up to an Ethernet connection to see if you are able to discover and connect to the Web interface in an attempt to determine whether the unit is functional.
answered Nov 7, 2014 by userid0 Veteran of the Digi Community (2,158 points)
0 votes

The cable itself is a Cisco RJ45 to Console cable.

I have attempted to connect an ethernet to the connection port, and for some reason it doesn't get an IP address. I've reset the device at least 4 times thinking maybe I just didn't hold it down long enough.

I've checked the router, and even scanned the network using a network ip scanner, and it doesn't show up, but the activity light does show up showing it's got connectivity.

Any ideas?
answered Nov 10, 2014 by bradjtrammell New to the Community (4 points)
0 votes
I was able to connect to the digi after making some changes to the network adapter on my local computer. However the COM connection is still not working.

I am trying to control the Roamer and Phantom on a rack of Rackable Systems, and can't seem to find a proper RJ45 pin-out using ethernet, does anyone have a proper pin out of the colors needed to be matched for each end?

I'm at my wits-end trying to get connected to these machines. The digi works, I can connect to it, I get the menu and everything, however if I attempt to connect to a port, it just sits there saying "Connecting to port" and then after 30 or so seconds it times out.

I realize this may be something that Digi does not support, however I would be eternally grateful if someone could give me the proper pin out for Cat5e with colors and everything, seeing as how I can't seem to find it anywhere else (or if you have luck finding it, the link referencing the matching colors)

Thank you.
answered Nov 10, 2014 by bradjtrammell New to the Community (4 points)
0 votes
Most console connections simply use a straight through network cable.

Based on your description of the connection timing out, it sounds more configuration.

Do you have the serial ports set for console server? See page 52:


How are you connecting to the port (i.e. port access menu, telnet, ssh)?

Are you able to connect to the console port on your Cisco?
answered Nov 10, 2014 by userid0 Veteran of the Digi Community (2,158 points)
edited Nov 10, 2014 by userid0
0 votes
Thank you for your answer. I have tried several different types of cables going from the device to the rackable systems, including normal, crossover, and roll over, and non of them seem to work.

I can only seem to connect to the Digi using SSH, Telnet or the web access, I can not use the COM port method (com port on desktop to RJ45 - Console Port on Digi), it will not connect or it does connect but shows no output.

I have modified my serial port configuration and this is what it currently looks like:

Host Mode: Console Server
Type: Other
Rackable Systems Mgmt Card: Enable
Enable/Disable Assigned IP: Enable
Assigned IP:
Port: 7001
Protocol: SSH

-- The rest is default and hasn't been changed.
answered Nov 10, 2014 by bradjtrammell New to the Community (4 points)
edited Nov 10, 2014 by bradjtrammell
0 votes
Also, I created a straight-through ethernet cable and it was not able to connect, same with a cross-over cable. I've also tried a roll over cable. I'm not sure what the wire configuration needs to be for the Rackable Roamer/Phantom to be able to communicate with the Digi.
answered Nov 10, 2014 by bradjtrammell New to the Community (4 points)
0 votes
You might want to test the port using a loopback cable/plug:


When connecting to the port, anything typed should echo back. If not, it suggests there is a problem with the hardware.
answered Nov 11, 2014 by userid0 Veteran of the Digi Community (2,158 points)
Well I tried making the loopback plug twice (just to make sure I made it correctly the first time) and there is no activity detected in any of the ports, no lights go on, when I connect to the ports, except the in use light, then that goes off once it times out. I'm assuming I got a bum device. Could it be software, or is this proof that it is hardware related?
this looks to be a problem with the hardware.  You should contact Digi Tech. Support to determine whether the unit should be sent in for repair.
0 votes

I was having the same issue when I first got my Digi CM 16. A Cisco console cable will not work with this device. The Cisco console cable uses a Cisco proprietary rollover pin out. To locally console into the Digi CM you will need a regular straight through Ethernet cable with a serial to Ethernet adapter. This accomplishes the same idea as a Cisco console cable but with a straight through pin out. I did not feeling buying the serial to Ethernet adapter, so I initially accessed the Digi via the web interface with HTTPS using the Digi's default IP (You will also need to set you computer to be on the same subnet as the default IP for the Digi). Once your in you can set up an IP of you choosing or use DCHP and turn on SSH. Now you can SSH into the Digi and not have to worry about a console connection.

Also check out this video which is fairly helpful if you are a Digi first time user.
answered Sep 11, 2016 by westj New to the Community (1 point)