Home/Support/Support Forum/sys_hw_init not returning
New and improved user forum site going live on 12/6 (All users will need to reset their password when the new forum is active)

sys_hw_init not returning

0 votes
I recently tried reflashing a Programmable XBee-PRO 900HP with the 10K (vs 200K) firmware. The unit now appears to be "bricked" insofar as the sys_hw_init() call never returns (when I debug the bootloader). I've tried everything I can think of to get it to respond but I get nothing. Any ideas or do I need to send this thing back?
asked May 27, 2013 in Multipoint Proprietary by jefffhaynes New to the Community (20 points)

Please log in or register to answer this question.

1 Answer

0 votes
I am having a similar problem in that it takes my setup (200K 8075 firmware, same platform) about 60 seconds to return from sys_hw_init() before proceeding to the next initialization function.

sys_xbee_init() and sys_app_banner are fine.

I've noticed when I run other sample projects, they do not take long. I am also getting garbage in my serial port whenever attempting to follow along with my printf statements during debug execution. I don't get this garbage when using builds from the SDK example projects.
answered Aug 10, 2020 by D2K New to the Community (16 points)